Resolved
Reports of errors trying to load a payment session

Started
April 14, 2022 at 8:07 AM
Status
Resolved after less than a minute

Impact

Major outage
Affected
Hosted invoices service
  • Resolved
    April 14, 2022 at 8:07 AM

    We are currently investigating this incident.

  • Monitoring
    April 13, 2022 at 6:12 PM

    We are currently investigating this incident.

  • Investigating
    April 13, 2022 at 5:15 PM

    We are currently investigating this incident.

  • Identified
    April 13, 2022 at 4:01 PM

    We are currently investigating this incident.