Resolved
Outage of the Hosted invoice service

Started
October 29, 2023 at 10:41 AM
Status
Resolved after 4 minutes

Impact

Major outage
Affected
Hosted invoices service
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.